OpenSSH < 5.9 Multiple DoS

medium Nessus Plugin ID 17703


The SSH server on the remote host has multiple denial of service vulnerabilities.


According to its banner, the version of OpenSSH running on the remote host is prior to version 5.9. Such versions are affected by multiple denial of service vulnerabilities :

- A denial of service vulnerability exists in the gss-serv.c 'ssh_gssapi_parse_ename' function. A remote attacker may be able to trigger this vulnerability if gssapi-with-mic is enabled to create a denial of service condition via a large value in a certain length field.

- On FreeBSD, NetBSD, OpenBSD, and other products, a remote, authenticated attacker could exploit the remote_glob() and process_put() functions to cause a denial of service (CPU and memory consumption).


Upgrade to OpenSSH 5.9 or later.

See Also

Plugin Details

Severity: Medium

ID: 17703

File Name: openssh_59.nasl

Version: 1.8

Type: remote

Published: 11/18/2011

Updated: 3/27/2024

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Vulnerability Information

CPE: cpe:/a:openbsd:openssh

Required KB Items: Settings/PCI_DSS, installed_sw/OpenSSH

Exploit Ease: No known exploits are available

Patch Publication Date: 9/6/2011

Vulnerability Publication Date: 7/7/2010

Reference Information

CVE: CVE-2010-4755, CVE-2011-5000

BID: 54114, 68757