SolarWinds Serv-U 15.3.0 < 15.3.2

high Nessus Plugin ID 168137

Description

The version of SolarWinds Serv-U installed on the remote host is prior to 15.3.2. It is, therefore, affected by a vulnerability as referenced in the serv-u_15_3_2 advisory.

- This vulnerability happens in the web client of Serv-U 15.3.1 and earlier release version. When the payload is entered in the directory creation option, it will throw an error and then the payload executes.
(CVE-2022-38106)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Serv-U version 15.3.2 or later.

See Also

http://www.nessus.org/u?a103b9da

Plugin Details

Severity: High

ID: 168137

File Name: solarwinds_serv-u_15_3_2.nasl

Version: 1.2

Type: remote

Agent: windows, macosx, unix

Family: FTP

Published: 11/23/2022

Updated: 11/23/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.6

CVSS v2

Risk Factor: High

Base Score: 7.3

Temporal Score: 5.4

Vector: CVSS2#AV:N/AC:L/Au:M/C:C/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS Score Source: CVE-2022-38106

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:serv-u:serv-u:*:*:*:*:*:*:*:*, cpe:2.3:a:solarwinds:serv-u:*:*:*:*:*:*:*:*, cpe:2.3:a:solarwinds:serv-u_file_server:*:*:*:*:*:*:*:*

Required KB Items: installed_sw/Serv-U

Exploit Ease: No known exploits are available

Patch Publication Date: 11/22/2022

Vulnerability Publication Date: 11/22/2022

Reference Information

CVE: CVE-2022-38106