Debian DLA-3141-1 : wordpress - LTS security update

critical Nessus Plugin ID 166002


The remote Debian host is missing a security-related update.


The remote Debian 10 host has packages installed that are affected by a vulnerability as referenced in the dla-3141 advisory.

- WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs. (CVE-2019-17670)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade the wordpress packages.

For Debian 10 buster, this problem has been fixed in version 5.0.17+dfsg1-0+deb10u1.

See Also

Plugin Details

Severity: Critical

ID: 166002

File Name: debian_DLA-3141.nasl

Version: 1.2

Type: local

Agent: unix

Published: 10/11/2022

Updated: 10/11/2022

Supported Sensors: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2019-17670


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:wordpress, p-cpe:/a:debian:debian_linux:wordpress-l10n, p-cpe:/a:debian:debian_linux:wordpress-theme-twentynineteen, p-cpe:/a:debian:debian_linux:wordpress-theme-twentyseventeen, p-cpe:/a:debian:debian_linux:wordpress-theme-twentysixteen, cpe:/o:debian:debian_linux:10.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 10/10/2022

Vulnerability Publication Date: 10/17/2019

Reference Information

CVE: CVE-2019-17670