Adobe Acrobat < 17.012.30262 / 20.005.30381 / 22.002.20191 Multiple Vulnerabilities (APSB22-39) (macOS)

high Nessus Plugin ID 163957

Synopsis

The version of Adobe Acrobat installed on the remote macOS host is affected by multiple vulnerabilities.

Description

The version of Adobe Acrobat installed on the remote macOS host is a version prior to 17.012.30262, 20.005.30381, or 22.002.20191. It is, therefore, affected by multiple vulnerabilities.

- Acrobat Reader DC versions 20.001.20085 (and earlier), 20.005.3031x (and earlier) and 17.012.30205 (and earlier) are affected by a use-after-free vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. (CVE-2022-24102, CVE-2022-24103, CVE-2022-24104)

- Acrobat Pro DC version 22.001.2011x (and earlier), 20.005.3033x (and earlier) and 17.012.3022x (and earlier) are affected by a use-after-free vulnerability that could lead to disclosure of sensitive memory.
An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file. (CVE-2022-28837)

- Acrobat Acrobat Pro DC version 22.001.2011x (and earlier), 20.005.3033x (and earlier) and 17.012.3022x (and earlier) are affected by a use-after-free vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file. (CVE-2022-28838)

- Acrobat Reader versions 22.001.20142 (and earlier), 20.005.30334 (and earlier) and 20.005.30334 (and earlier) are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file. (CVE-2022-35669)

- Use After Free (CWE-416) potentially leading to Arbitrary code execution (CVE-2022-35665)

- Improper Input Validation (CWE-20) potentially leading to Arbitrary code execution (CVE-2022-35666)

- Out-of-bounds Write (CWE-787) potentially leading to Arbitrary code execution (CVE-2022-35667)

- Improper Input Validation (CWE-20) potentially leading to Memory leak (CVE-2022-35668)

- Use After Free (CWE-416) potentially leading to Memory leak (CVE-2022-35670)

- Out-of-bounds Read (CWE-125) potentially leading to Memory leak (CVE-2022-35671, CVE-2022-35678)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe Acrobat version 17.012.30262 / 20.005.30381 / 22.002.20191 or later.

See Also

https://helpx.adobe.com/security/products/acrobat/apsb22-39.html

Plugin Details

Severity: High

ID: 163957

File Name: macos_adobe_acrobat_apsb22-39.nasl

Version: 1.5

Type: local

Agent: macosx

Published: 8/9/2022

Updated: 3/23/2023

Supported Sensors: Nessus Agent, Nessus

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2022-35667

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 6.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:acrobat

Required KB Items: installed_sw/Adobe Acrobat, Host/local_checks_enabled, Host/MacOSX/Version

Exploit Ease: No known exploits are available

Patch Publication Date: 8/9/2022

Vulnerability Publication Date: 4/12/2022

Reference Information

CVE: CVE-2022-35665, CVE-2022-35666, CVE-2022-35667, CVE-2022-35668, CVE-2022-35670, CVE-2022-35671, CVE-2022-35678

CWE: 125, 20, 416, 787

IAVA: 2022-A-0323-S