Microsoft Netlogon Elevation of Privilege (Zerologon) (Remote)

critical Nessus Plugin ID 140657
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The Netlogon service on the remote host is vulnerable to the zerologon vulnerability.

Description

The Netlogon service on the remote host is vulnerable to the zerologon vulnerability. An unauthenticated, remote attacker can exploit this, by spoofing a client credential to establish a secure channel to a domain controller using the Netlogon remote protocol (MS-NRPC). The attacker can then use this to change the computer's Active Directory (AD) password, and escalate privileges to domain admin.

In order for this plugin to run, you must disable 'Only use credentials provided by the user' in the scanner settings.

Solution

Refer to Microsoft's advisory for security guidance.

See Also

http://www.nessus.org/u?dfa970a7

http://www.nessus.org/u?f2e259c1

https://www.secura.com/blog/zero-logon

https://www.secura.com/pathtoimg.php?id=2055

https://github.com/SecuraBV/CVE-2020-1472

http://www.nessus.org/u?26edeb9b

https://www.kb.cert.org/vuls/id/490028

Plugin Details

Severity: Critical

ID: 140657

File Name: netlogon_zerologon_CVE-2020-1472.nbin

Version: 1.22

Type: remote

Agent: windows

Family: Windows

Published: 9/18/2020

Updated: 5/10/2021

Dependencies: dcetest.nasl, os_fingerprint.nasl

Risk Information

CVSS Score Source: CVE-2020-1472

VPR

Risk Factor: Critical

Score: 10

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 8.1

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 10

Temporal Score: 9.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:microsoft:windows

Required KB Items: Host/OS, Services/epmap

Excluded KB Items: global_settings/supplied_logins_only

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Patch Publication Date: 8/11/2020

Vulnerability Publication Date: 8/11/2020

Reference Information

CVE: CVE-2020-1472

IAVA: 2020-A-0438, 0001-A-0647