Avirt Multiple Product HTTP Proxy Overflow

High Nessus Plugin ID 11715


The remote host is running a suite of applications that are affected by a buffer overflow vulnerability.


The remote host is running a product from the Avirt Gateway Suite. The version installed is affected by a buffer overflow vulnerability.

It was possible to kill the HTTP proxy by sending a specially crafted request with a too long header. An attacker could exploit this to deny service to the affected application. It may also be possible to exploit this to execute arbitrary code.


There is no known solution at this time.

See Also


Plugin Details

Severity: High

ID: 11715

File Name: avirt_proxy_overflow.nasl

Version: $Revision: 1.16 $

Type: remote

Family: Web Servers

Published: 2003/06/11

Modified: 2016/09/26

Dependencies: 10107, 11153

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:U/RC:ND

Vulnerability Information

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2002/01/17

Reference Information

CVE: CVE-2002-0133

BID: 3904

OSVDB: 6804