Photon OS 2.0 : Zsh / Python3 / Xerces / Mercurial / Pmd / Pycrypto / Net / Python2 / Util / Mysql / Paramiko / Binutils / Patch / Sqlite (PhotonOS-PHSA-2018-2.0-0037)

High Nessus Plugin ID 111297

Synopsis

The remote PhotonOS host is missing multiple security updates.

Description

An update of {'mercurial', 'python2', 'zsh', 'pycrypto', 'patch', 'binutils', 'paramiko', 'httpd', 'mysql', 'xerces-c', 'util-linux', 'net-snmp', 'python3', 'sqlite'} packages of Photon OS has been released.

Solution

Update the affected Zsh / Python3 / Xerces / Mercurial / Pmd / Pycrypto / Net / Python2 / Util / Mysql / Paramiko / Binutils / Patch / Sqlite packages.

See Also

http://www.nessus.org/u?5a24de30

Plugin Details

Severity: High

ID: 111297

File Name: PhotonOS_PHSA-2018-2_0-0037.nasl

Version: 1.1

Type: local

Published: 2018/07/24

Modified: 2018/07/24

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2017-12627

CVSSv2

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSSv3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:vmware:photonos:zsh, p-cpe:/a:vmware:photonos:python3, p-cpe:/a:vmware:photonos:xerces, p-cpe:/a:vmware:photonos:mercurial, p-cpe:/a:vmware:photonos:pmd, p-cpe:/a:vmware:photonos:pycrypto, p-cpe:/a:vmware:photonos:net, p-cpe:/a:vmware:photonos:python2, p-cpe:/a:vmware:photonos:util, p-cpe:/a:vmware:photonos:mysql, p-cpe:/a:vmware:photonos:paramiko, p-cpe:/a:vmware:photonos:binutils, p-cpe:/a:vmware:photonos:patch, p-cpe:/a:vmware:photonos:sqlite, cpe:/o:vmware:photonos:2.0

Required KB Items: Host/local_checks_enabled, Host/PhotonOS/release, Host/PhotonOS/rpm-list

Patch Publication Date: 2018/04/23

Reference Information

CVE: CVE-2017-12627, CVE-2017-18207, CVE-2018-1303, CVE-2018-2573, CVE-2018-2583, CVE-2018-2612, CVE-2018-2622, CVE-2018-2640, CVE-2018-2665, CVE-2018-2668, CVE-2018-2703, CVE-2018-6594, CVE-2018-6951, CVE-2018-7208, CVE-2018-7549, CVE-2018-7643, CVE-2018-7738, CVE-2018-7750, CVE-2018-8740, CVE-2018-1000030, CVE-2018-1000116, CVE-2018-1000117, CVE-2018-1000132

BID: 102678, 102681, 102682, 102704, 102706, 102708, 102709, 102710, 103044, 103077, 103219, 103264, 103367, 103466, 103522, 103713, 104527