nginx < 1.13.2 Integer Overflow Vulnerability

Medium Nessus Plugin ID 105359

Synopsis

The remote web server is affected by an integer overflow vulnerability.

Description

According to the self-reported version in its response header, the version of nginx hosted on the remote web server is < 1.13.2. It is, therefore, affected by an integer overflow vulnerability

Solution

Upgrade to nginx version 1.13.2 or later.

See Also

http://www.nessus.org/u?12a2e3b9

http://www.nessus.org/u?a93efaaf

http://nginx.org/en/security_advisories.html

Plugin Details

Severity: Medium

ID: 105359

File Name: nginx_1_13_2.nasl

Version: 1.11

Type: remote

Family: Web Servers

Published: 2017/12/18

Updated: 2018/12/13

Dependencies: 106375

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-7529

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2017/07/11

Vulnerability Publication Date: 2017/07/11

Reference Information

CVE: CVE-2017-7529

BID: 99534