PHP < 5.4.38, < 5.5.22, < 5.6.6 HTTP Header Content Injection XSS

medium Log Correlation Engine Plugin ID 802020
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The specific version of PHP that this Apache server is running is vulnerable to a HTTP Header Content Injection XSS attack.

Description

PHP contains a flaw that allows a cross-site scripting (XSS) attack. This flaw exists because the header() function does not filter input passed via HTTP headers before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.Technical Information: This vulnerability is only present when using Internet Explorer.

Solution

It has been reported that this has been fixed. Please refer to the product listing for upgraded versions that address this vulnerability.

See Also

http://php.net/ChangeLog-5.php

http://www.php.net/

https://bugs.php.net/bug.php?id=68978

https://bugs.launchpad.net/ubuntu/+source/php5/+bug/1594041

http://seclists.org/oss-sec/2016/q2/570

Plugin Details

Severity: Medium

ID: 802020

Family: Web Servers

Published: 7/12/2016

Updated: 7/12/2016

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2/19/2015

Vulnerability Publication Date: 2/3/2015

Reference Information

CVE: CVE-2015-8935