PHP < 5.4.38, < 5.5.22, < 5.6.6 HTTP Header Content Injection XSS

Medium Log Correlation Engine Plugin ID 802020


The specific version of PHP that this Apache server is running is vulnerable to a HTTP Header Content Injection XSS attack.


PHP contains a flaw that allows a cross-site scripting (XSS) attack. This flaw exists because the header() function does not filter input passed via HTTP headers before returning it to users. This may allow a remote attacker to create a specially crafted request that would execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.Technical Information: This vulnerability is only present when using Internet Explorer.


It has been reported that this has been fixed. Please refer to the product listing for upgraded versions that address this vulnerability.

See Also

Plugin Details

Severity: Medium

ID: 802020

Family: Web Servers

Published: 2016/07/12

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2015/02/19

Vulnerability Publication Date: 2015/02/03

Reference Information

CVE: CVE-2015-8935