Squid < 3.5.17, 4.0.9 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 802013
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The specific version of Squid that the system is running is reportedly affected by multiple vulnerabilities.

Description

The specific version of Squid that the system is running is reportedly affected by the following vulnerabilities:

- Squid contains a flaw in esi/Esi.cc that is triggered as input is not properly validated when handling ESI responses. This may allow a remote attacker to disclose the server stack layout. (CVE-2016-4053)

- Squid contains an overflow condition in esi/Esi.cc that is triggered as user-supplied input is not properly validated when handling ESI responses. This may allow a remote attacker to cause a buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (CVE-2016-4054)

- Squid contains an assertion flaw in esi/Esi.cc that is triggered as input is not properly validated when handling ESI responses. This may allow a remote attacker to terminate the service. (CVE-2016-4052)

- Squid contains an overflow condition that is triggered as user-supplied input is not properly validated when processing the length of content lines in reports by the cachemgr.cgi tool. This may allow a remote attacker to cause a buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (CVE-2016-4051)

Solution

It has been reported that this has been fixed. Please refer to the product listing for upgraded versions that address this vulnerability. In addition, the vendor has released a patch for some older versions.

See Also

http://community.ubnt.com/t5/EdgeMAX-Updates-Blog/EdgeMAX-EdgeRouter-software-release-v1-9-0/ba-p/1643332

http://www.squid-cache.org/

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=823968

http://www.squid-cache.org/Advisories/SQUID-2016_6.txt

http://www.ubuntu.com/usn/usn-2995-1/

https://www.debian.org/security/2016/dsa-3625

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00010.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00040.html

http://seclists.org/oss-sec/2016/q2/117

http://seclists.org/bugtraq/2016/Jul/104

https://bugzilla.redhat.com/show_bug.cgi?id=1359203

http://www.squid-cache.org/Advisories/SQUID-2016_5.txt

Plugin Details

Severity: High

ID: 802013

Family: Web Servers

Published: 8/29/2016

Updated: 8/29/2016

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 4/20/2016

Vulnerability Publication Date: 4/20/2016

Reference Information

CVE: CVE-2016-4051, CVE-2016-4052, CVE-2016-4053, CVE-2016-4054