PHP < 5.5.37, 5.6.23 Use-After-Free Remote Code Execution.

high Log Correlation Engine Plugin ID 802011
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The specific version of PHP that the server is running is vulnerable to a user-after-free remote code execution.


PHP contains a use-after-free error in the garbage collection algorithm in ext/spl/spl_array.c. This may allow a remote attacker to dereference already freed memory and potentially execute arbitrary code.
Technical Information: This issue was introduced in version 5.3.0.

Note: Programming language vulnerability. This code is used in a wide variety of software and the issue may manifest in a number of different ways.

This issue is reportedly not exploitable in the 7.x branch, though it still appeared as fixed in version 7.0.8's changelog.


It has been reported that this has been fixed. Please refer to the product listing for upgraded versions that address this vulnerability.

See Also

Plugin Details

Severity: High

ID: 802011

Family: Web Servers

Published: 8/23/2016

Updated: 8/23/2016

Risk Information


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 12/3/2015

Vulnerability Publication Date: 6/21/2016

Reference Information

CVE: CVE-2016-5771