PHP < 5.5.37, 5.6.23, 7.0.8 Multiple Vulnerabilties

Critical Log Correlation Engine Plugin ID 802010

Synopsis

The specific version of PHP that the system is running is reportedly affected by multiple vulnerabilities.

Description

The specific version of PHP that the system is running is reportedly affected by the following vulnerabilities:

- PHP contains an integer overflow condition in the json_decode() and json_utf8_to_utf16() functions in ext/standard/php_smart_str.h. The issue is triggered as user-supplied input is not properly validated. This may allow a remote attacker to cause a heap-based buffer overflow, causing a denial of service in a process linked against PHP or potentially allowing the execution of arbitrary code.

- PHP contains an out-of-bounds read flaw in the pass2_no_dither() function in ext/gd/libgd/gd_topal.c that may allow a remote attacker to crash a process utilizing PHP or potentially disclose memory contents.

- PHP contains an integer overflow condition in ext/standard/string.c. The issue is triggered as user-supplied input is not properly validated when handling string lengths. This may allow a remote attacker to have an unspecified impact.

- PHP contains a double-free flaw in the _php_mb_regex_ereg_replace_exec() function in ext/mbstring/php_mbregex.c that is triggered when handling a failed callback execution. This may allow a remote attacker to potentially execute arbitrary code. (CVE-2016-5768)

- PHP contains a NULL pointer dereference flaw in the _gdScaleVert() function in ext/gd/libgd/gd_interpolation.c that is triggered during the handling of _gdContributionsCalc return values. This may allow a remote attacker to cause a denial of service in a process linked against PHP.

- PHP contains an integer overflow condition in ext/spl/spl_directory.c. The issue is triggered by an int/size_t confusion issue. This may allow a remote attacker to have an unspecified impact. (CVE-2016-5770)

- PHP contains an integer overflow condition in ext/mcrypt/mcrypt.c. The issue is triggered as user-supplied input is not properly validated when handling data values. This may allow a remote attacker to cause a heap-based buffer overflow, resulting in a denial of service in a process linked against PHP or potentially allowing the execution of arbitrary code. (CVE-2016-5769)

- PHP contains an integer overflow condition in the nl2br() function in ext/standard/string.c. The issue is triggered as user-supplied input is not properly validated when handling new_length values. This may allow a remote attacker to have an unspecified impact.

- PHP contains an integer overflow condition in multiple functions in ext/standard/string.c. The issue is triggered as user-supplied input is not properly validated when handling string values. This may allow a remote attacker to have an unspecified impact.

- PHP contains a double-free flaw in the php_wddx_process_data() function in ext/wddx/wddx.c that is triggered during the handling of specially crafted XML content. This may allow a remote attacker to potentially execute arbitrary code. (CVE-2016-5772)

- PHP contains an integer overflow condition in the gdImagePaletteToTrueColor() function in ext/gd/libgd/gd.c. The issue is triggered as user-supplied input is not properly validated. This may allow a remote attacker to cause a heap-based buffer overflow, resulting in a denial of service in a process linked against PHP or potentially allowing the execution of arbitrary code. (CVE-2016-5767)

- PHP contains an invalid free flaw in the phar_extract_file() function in ext/phar/phar_object.c. This may allow a remote attacker to have an unspecified impact. (CVE-2016-4473)

- PHP contains an integer overflow condition in the _gd2GetHeader() function in ext/gd/libgd/gd_gd2.c. The issue is triggered as user-supplied input is not properly validated. This may allow a remote attacker to cause a heap-based buffer overflow, resulting in a denial of service in a process linked against PHP or potentially allowing the execution of arbitrary code. (CVE-2016-5766)

Solution

It has been reported that this has been fixed. Please refer to the product listing for upgraded versions that address this vulnerability.

See Also

http://www.php.net/

https://bugs.php.net/bug.php?id=72275

http://php.net/ChangeLog-7.php#7.0.8

http://php.net/ChangeLog-5.php#5.6.23

http://php.net/ChangeLog-5.php#5.5.37

https://bugs.php.net/bug.php?id=72298

https://bugs.php.net/bug.php?id=72400

https://bugs.php.net/bug.php?id=72402

http://community.ubnt.com/t5/EdgeMAX-Updates-Blog/EdgeMAX-EdgeRouter-software-release-v1-9-0/ba-p/1643332

http://lists.opensuse.org/opensuse-security-announce/2016-07/msg00004.html

http://www.ubuntu.com/usn/usn-3045-1/

http://seclists.org/oss-sec/2016/q2/587

https://bugs.php.net/bug.php?id=72407

https://bugs.php.net/bug.php?id=72262

https://bugs.php.net/bug.php?id=72455

https://bugs.php.net/bug.php?id=72782

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00025.html

http://lists.opensuse.org/opensuse-security-announce/2016-08/msg00039.html

https://bugs.php.net/bug.php?id=72268

https://bugs.php.net/bug.php?id=72403

https://bugs.php.net/bug.php?id=72340

https://bugs.php.net/bug.php?id=72446

https://bugs.php.net/bug.php?id=72321

https://bugs.php.net/bug.php?id=72339

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=829014

https://security-tracker.debian.org/tracker/CVE-2016-5766

http://www.ubuntu.com/usn/usn-3030-1/

https://www.debian.org/security/2016/dsa-3619

http://seclists.org/bugtraq/2016/Jul/68

Plugin Details

Severity: Critical

ID: 802010

Family: Web Servers

Published: 2016/08/23

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2016/07/22

Vulnerability Publication Date: 2016/06/21

Reference Information

CVE: CVE-2016-5768, CVE-2016-5770, CVE-2016-5769, CVE-2016-5772, CVE-2016-5767, CVE-2016-4473, CVE-2016-5766