cURL >= 7.21.0 and < 7.49.0 MitM Spoofing

medium Log Correlation Engine Plugin ID 802007
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The specific version of cURL that the client is running is vulnerable to a man-in-the-middle spoofing attack.

Description

cURL and libcurl with mbedTLS and PolarSSL contain a flaw as TLS certificates are not properly validated. By spoofing the TLS/SSL server via a certificate that appears valid, an attacker with the ability to intercept network traffic (e.g. MitM, DNS cache poisoning) can disclose and optionally manipulate transmitted data.
Technical Information: This flaw only exists when libcurl is built to use mbedTLS or PolarSSL as TLS backend.

Solution

It has been reported that this has been fixed. Please refer to the product listing for upgraded versions that address this vulnerability. In addition, the vendor has released a patch for some older versions.

See Also

https://curl.haxx.se/docs/adv_20160518.html

http://seclists.org/oss-sec/2016/q2/362

Plugin Details

Severity: Medium

ID: 802007

Family: Web Clients

Published: 7/14/2016

Updated: 7/14/2016

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 5/18/2016

Vulnerability Publication Date: 5/18/2016

Reference Information

CVE: CVE-2016-3739