OpenSSL < 0.9.8zd / 1.0.0p / 1.0.1k Key Decryption Vulnerability

medium Log Correlation Engine Plugin ID 801936
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

The remote host is running a version of OpenSSL which is vulnerable to an RSA-to-EXPORT_RSA downgrade attack which facilitates brute-force key decryption.

Solution

Upgrade to OpenSSL 0.9.8zd, 1.0.0p, 1.0.1k, or later.

See Also

https://www.openssl.org/news/openssl-1.0.1-notes.html

https://www.openssl.org/news/vulnerabilities.html

http://openssl.org/news/secadv_20150319.txt

Plugin Details

Severity: Medium

ID: 801936

Family: Web Servers

Published: 3/19/2015

Updated: 3/19/2015

Nessus ID: 80566, 80567, 80568

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 3/19/2015

Vulnerability Publication Date: 3/19/2015

Reference Information

CVE: CVE-2015-0204

BID: 71936