OpenSSL Heartbeat Information Disclosure (Heartbleed)

high Log Correlation Engine Plugin ID 801617
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote service is affected by an information disclosure
vulnerability.

Description

Versions of OpenSSL 1.0.1 prior to 1.0.1g may contain the following vulnerability:

- A missing bounds check in the handling of the TLS heartbeat extension can be
used to reveal up to 64k of memory to a connected client or server. (CVE-2014-0160)

Solution

Upgrade to OpenSSL 1.0.1g or later.

Alternatively, recompile OpenSSL with the '-DOPENSSL_NO_HEARTBEATS'
flag to disable the vulnerable functionality.

See Also

http://heartbleed.com/

http://eprint.iacr.org/2014/140

http://www.openssl.org/news/vulnerabilities.html#2014-0160

Plugin Details

Severity: High

ID: 801617

Family: Web Servers

Nessus ID: 73412, 73404

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.4

Temporal Score: 8.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Reference Information

CVE: CVE-2014-0160

OSVDB: 105465