cURL/libcURL 'tailmatch()' Function Information Disclosure Vulnerability

medium Log Correlation Engine Plugin ID 801394
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The cURL program is a library and command-line tool for transferring data using various protocols, including HTTP, FTP, and LDAP. A vulnerable version of cURL was detected from the host.

Description

A flaw was found in the way libcurl matched domains associated with cookies. This could lead to cURL sending the wrong cookie if only part of the domain name matched the domain associated with the cookie, disclosing the cookie to unrelated hosts. (CVE-2013-1944)

Affected versions prior to 7.30.0 are vulnerable.


Solution

Upgrade the affected packages; the next version of cURL that fixes the issue is cURL 7.21.7.

See Also

http://curl.haxx.se/docs/adv_20130412.html

Plugin Details

Severity: Medium

ID: 801394

Family: Web Clients

Published: 7/5/2013

Updated: 7/5/2013

Nessus ID: 66206

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 6/25/2012

Vulnerability Publication Date: 4/24/2012

Reference Information

CVE: CVE-2013-1944

BID: 59058