Apache 2.2.x < 2.2.25 Remote Denial of Service Vulnerability

medium Log Correlation Engine Plugin ID 801383
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server uses a version of Apache that is affected by a remote denial-of-service vulnerability.

Description

Apache versions earlier than 2.2.25 are affected by a remote denial-of-service vulnerability because the 'mod_dav.c' source file fails to properly determine whether DAV is enabled for a URI. Specifically, this issue occurs when sending a URI MERGE request handled by the 'mod_dav_svn' module with the source href pointing to a URI not configured for DAV. An attacker can exploit this issue to cause a segmentation fault.

Solution

Upgrade to Apache version 2.2.25 or later.

See Also

https://bugzilla.redhat.com/show_bug.cgi?id=983549

http://www.apache.org/dist/httpd/Announcement2.2.html

Plugin Details

Severity: Medium

ID: 801383

Family: Web Servers

Published: 7/12/2012

Updated: 7/12/2012

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 7/10/2012

Vulnerability Publication Date: 7/10/2012

Reference Information

CVE: CVE-2013-1862, CVE-2013-1896

BID: 59826, 61129