Mozilla Thunderbird 3.0.x < 3.0.11 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 801367

Synopsis

The remote host has an email client installed that is vulnerable to multiple attack vectors.

Description

Versions of Thunderbird 3.0.x earlier than 3.0.11 are potentially affected by multiple vulnerabilities :

- Multiple memory corruption issues could lead to arbitrary code execution. (MFSA 2010-74)

- On the Windows platform, when 'document.write()' is called with a very long string a buffer overflow could be triggered. (MFSA 2010-75)

- Downloadable fonts could expose vulnerabilities in the underlying OS font code. (MFSA 2010-78)

Solution

Upgrade to Mozilla Thunderbird 3.0.11 or later.

See Also

http://.mozilla.org/security/announce/2010/mfsa2010-74.html

http://.mozilla.org/security/announce/2010/mfsa2010-75.html

http://.mozilla.org/security/announce/2010/mfsa2010-78.html

http://.mozilla.org/security/known-vulnerabilities/thunderbird30.html#thunderbird3.0.11

Plugin Details

Severity: High

ID: 801367

Family: SMTP Clients

Published: 12/10/2010

Updated: 12/10/2010

Nessus ID: 51122

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 12/9/2010

Vulnerability Publication Date: 12/9/2010

Reference Information

CVE: CVE-2010-3776, CVE-2010-3768, CVE-2010-3777, CVE-2010-3778, CVE-2010-3769

BID: 45352, 45344, 45347, 45345, 45348