Mozilla Firefox < 3.0.18 / 3.5.8 / 3.6 Multiple Vulnerabilities
High Log Correlation Engine Plugin ID 801279
The remote host has a web browser installed that is vulnerable to multiple attack vectors.
The remote host is running a version of Mozilla Firefox earlier than 3.0.18, 3.5.8, 3.6. Such versions are potentially affected by multiple vulnerabilities : - Several crashes can result in arbitrary code execution. (MFSA 2010-01) - The implementation of 'Web Workers' contains an error in its handling of array data types when processing posted messages. (MFSA 2010-02) - The HTML parser incorrectly frees used memory when insufficient space is available to process remaining input. (MFSA 2010-03) - A cross-site scripting issue due to 'window.dialogArguments' being readable cross-domain. (CVE-2010-04) - A cross-site scripting issue when using SVG documents and binary Content-Type. (MFSA 2010-05) - Multiple crashes can result in arbitrary code execution. (MFSA 2010-011) - A cross-site scripting issue when using 'addEventListener' and 'setTimeout' on a wrapped object. (MFSA 2010-12) - It is possible to corrupt a user's XUL cache. (MFSA 2010-14)
Upgrade to Mozilla Firefox 3.0.18, 3.5.8, 3.6, or later.