Mozilla Firefox < 1.5.0.1 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 801243
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running an older version of the Firefox browser. The installed version of Firefox is reported to be prone to a cross-domain scripting flaw. An attacker exploiting this flaw would need to be able to convince a user to browse to a malicious URI. Successful exploitation would result in the attacker executing malicious script code within the Firefox browser. In addition, the remote browser is vulnerable to a memory corruption and authentication bypass flaw. An attacker exploiting these flaws would be able to execute arbitrary code on the remote browser or gain access to critical functions.

Solution

Upgrade to version 1.5.0.1 or higher.

See Also

http://.mozilla.org

Plugin Details

Severity: High

ID: 801243

Family: Web Clients

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.5

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Exploitable With

Metasploit (Firefox location.QueryInterface() Code Execution)

Reference Information

CVE: CVE-2005-4134, CVE-2006-0292, CVE-2006-0296, CVE-2006-0295, CVE-2006-0294, CVE-2006-0297, CVE-2006-0298, CVE-2006-0299, CVE-2006-0293, CVE-2006-0496

BID: 16476, 16427, 16741