Mozilla SeaMonkey < 1.1.18 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 801235
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is running a web browser that is vulnerable to multiple attack vectors.

Description

The remote host is running a version of Mozilla SeaMonkey earlier than 1.1.18. Such versions are potentially affected by multiple vulnerabilities :

- A heap overflow vulnerability in the code that handles regular expressions in certificate names. (MFSA-2009-43)

- A mismatch in the treatment of domain names in SSL certificates between SSL clients and the Certificate Authorities which issue server certificates. (MFSA-2009-42)


Solution

Upgrade to SeaMonkey 1.1.18 or later.

See Also

http://.mozilla.org/security/announce/2009/mfsa2009-42.html

http://.mozilla.org/security/announce/2009/mfsa2009-43.html

http://.mozilla.org/security/known-vulnerabilities/seamonkey11.html#seamonkey1.1.18

Plugin Details

Severity: High

ID: 801235

Family: Web Clients

Published: 9/3/2009

Updated: 9/3/2009

Nessus ID: 40874

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 9/3/2009

Vulnerability Publication Date: 7/30/2009

Reference Information

CVE: CVE-2009-2404, CVE-2009-2408

BID: 35888, 35891