Mozilla Firefox < 1.5.0.2 or 1.0.8 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 801220

Synopsis

The remote host is missing a critical security patch or upgrade.

Description

The remote host is using Firefox. The installed version of Firefox contains various security issues, several of which are critical as they can be easily exploited to execute arbitrary shell code on the remote host. The version of Firefox is vulnerable to multiple denial of service attacks, overflows, information disclosure, privilege escalation, and other issues. An attacker exploiting these flaws would need to be able to convince a Firefox user to browse to a malicious URI.

Solution

Upgrade to version 1.5.0.2, 1.0.8 or higher.

See Also

http://.mozilla.org

Plugin Details

Severity: High

ID: 801220

File Name: 801220.prm

Family: Web Clients

Risk Information

Risk Factor: High

CVSSv2

Base Score: 5.4

Temporal Score: 4.5

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Exploitable With

Metasploit (Firefox location.QueryInterface() Code Execution)

Reference Information

CVE: CVE-2006-0296, CVE-2005-4134, CVE-2006-0294, CVE-2006-0295, CVE-2006-0297, CVE-2006-0298, CVE-2006-0299, CVE-2006-0748, CVE-2006-0749, CVE-2006-1045, CVE-2006-1731, CVE-2006-1732, CVE-2006-1733, CVE-2006-1734, CVE-2006-1735, CVE-2006-1736, CVE-2006-1737, CVE-2006-1738, CVE-2006-1739, CVE-2006-1740, CVE-2006-1790, CVE-2006-1742, CVE-2006-1724, CVE-2006-1529, CVE-2006-1530, CVE-2006-0292, CVE-2006-0293, CVE-2006-1531, CVE-2006-1723, CVE-2006-1725, CVE-2006-1726, CVE-2006-1727, CVE-2006-1728, CVE-2006-1729, CVE-2006-1730

BID: 17499, 17516, 16476