VLC Media Player < 1.1.9 Heap Corruption Vulnerability

High Log Correlation Engine Plugin ID 801170

Synopsis

The remote host contains an application that allows arbitrary code execution.

Description

The remote host contains VLC player, a multi-media application.

Versions of VLC media player earlier than 1.1.9 are potentially affected by heap corruption vulnerability in the MP4 demultiplexer which could lead to arbitrary code execution.

Solution

Upgrade to VLC Media Player version 1.1.9 or later.

See Also

http://.videolan.org/security/sa1103.html

http://.videolan.org/vlc/releases/1.1.9.html

git.videolan.org/?p=vlc.git;a=commit;h=5637ca8141bf39f263ecdb62035d2cb45c740821

Plugin Details

Severity: High

ID: 801170

File Name: 801170.prm

Family: Web Clients

Published: 2011/04/12

Nessus ID: 53405

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2011/04/12

Vulnerability Publication Date: 2011/04/09

Reference Information

CVE: CVE-2011-1684

BID: 47293