VLC Media Player < 2.0.6 ASF Demuxer Buffer Overflow

high Log Correlation Engine Plugin ID 801169
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains an application that is affected by a buffer overflow vulnerability

Description

The remote host contains VLC player, a multi-media application.

Versions of VLC media player earlier than 2.0.6 are potentially affected by a a buffer overflow vulnerability related to the ASF demuxer plugin

Solution

Upgrade to VLC Media Player version 2.0.6 or later.

See Also

http://www.videolan.org/security/sa1302.html

http://www.nessus.org/u?b8052708

http://trac.videolan.org/vlc/ticket/8024a

http://www.videolan.org/vlc/releases/2.0.6.html

Plugin Details

Severity: High

ID: 801169

Family: Web Clients

Published: 4/29/2013

Updated: 4/29/2013

Nessus ID: 66216

Risk Information

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 1/17/2012

Vulnerability Publication Date: 1/11/2012

Reference Information

CVE: CVE-2013-1954

BID: 57333