MySQL < 4.0.21 Remote FULLTEXT Search DoS

medium Log Correlation Engine Plugin ID 801166
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to a Denial of Service (DoS) attack.

Description

The remote host is running a version of MySQL that is older than version 4.0.21.
It is vulnerable to a flaw that may allow an attacker to cause a Denial Of Service. An attacker can exploit this vulnerability by using the FULLTEXT search functionality.

Solution

Upgrade to version 4.0.21 or higher.

See Also

bugs.mysql.com/bug.php?id=3870

http://.novell.com/linux/security/securitysupport.html

http://.gentoo.org/security/en/glsa/glsa-200410-22.xml

http://.debian.org/security/2005/dsa-707

http://.ubuntulinux.org/usn/usn-109-1

rhn.redhat.com/errata/RHSA-2004-611.html

bugs.mysql.com/bug.php?id=3933

Plugin Details

Severity: Medium

ID: 801166

Family: Database

Nessus ID: 15477

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Reference Information

CVE: CVE-2004-0956

BID: 11435, 11432