MySQL < 5.1.18 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 801164

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL installed on the remote host reportedly is affected by three issues :

- A user can rename a table without having DROP privileges.

-If a stored routine is declared as 'SQL SECURITY INVOKER', a user may be able to gain privileges by invoking that routine.

-A user with only ALTER privileges on a partitioned table can discover information about the table that should require SELECT privileges.

Solution

Upgrade to version 5.1.18 or higher.

See Also

bugs.mysql.com/bug.php?id=23675

bugs.mysql.com/bug.php?id=27515

bugs.mysql.com/bug.php?id=27337

dev.mysql.com/doc/refman/5.1/en/news-5-1-18.html

Plugin Details

Severity: Medium

ID: 801164

File Name: 801164.prm

Family: Database

Nessus ID: 25242

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3

Vector: CVSS2#AV:A/AC:H/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2007-2691, CVE-2007-2692, CVE-2007-2693

BID: 24008, 24011, 24016