MySQL Mysqlhotcopy Script Insecure Temporary File Creation

medium Log Correlation Engine Plugin ID 801162
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data.

Description

The remote host is running a version of MySQL that is older than version 3.23.49 or than 4.0.20. The version of the utility Mysqlhotcopy included in these versions of MySQL is reported to be prone to a vulnerability that may permit an attacker to overwrite arbitrary files on the database server with the privilege of the targeted user. Privilege escalation may also be possible. An attacker requires local interactive access in order to exploit this vulnerability.

Solution

Upgrade or patch according to vendor recommendations.

Plugin Details

Severity: Medium

ID: 801162

Family: Database

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Reference Information

CVE: CVE-2004-0457, CVE-2004-0835, CVE-2004-0837, CVE-2004-0957

BID: 10969, 11357