MySQL 6.0 < 6.0.9 CREATE TABLE Security Bypass

medium Log Correlation Engine Plugin ID 801145
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to security bypass attack.

Description

The version of MySQL 6.0 installed on the remote host is earlier than 6.0.9, and thus potentially affected by a security bypass vulnerability. The application allwos an attacker to bypass certain checks when creating a table with ceratin 'DATA DIRECTORY' and 'INDEX DIRECTORY' options that are within the MySQL home data directory.

Solution

Upgrade to MySQL Community Server version 6.0.9 or later.

See Also

marc.info/?l=oss-security&amp;amp;m=125908040022018&amp;amp;w=2

lists.mysql.com/commits/59711

bugs.mysql.com/bug.php?id=39277

Plugin Details

Severity: Medium

ID: 801145

Family: Database

Published: 2/3/2010

Updated: 2/3/2010

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 1/2/2009

Vulnerability Publication Date: 2/2/2010

Reference Information

CVE: CVE-2008-7247

BID: 38043