MySQL < 5.1.41 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 801137
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The remote host is running MySQL Community server &lt; 5.1.41. Such versions are potentially affected by multiple issues :

- The application fails to correctly handle the data directory path name if it contains symlinked directories in its path which could lead to a local privilege escalation. (Bug 32167)

- MySQL clients linked against OpenSSL did not check server certificates presented by a server linked against yaSSL. (Bug 47320)

- An error related to the handling of certain SELECT statements containing subqueries.

- A failure to preserve unspecified 'null_value' flags when executing statements that use the 'GeomFromWKB' function.


Solution

Upgrade to MySQL Community server 5.1.41 or later.

See Also

bugs.mysql.com/bug.php?id=47320

bugs.mysql.com/bug.php?id=47780

bugs.mysql.com/bug.php?id=48291

bugs.mysql.com/bug.php?id=39277

dev.mysql.com/doc/refman/5.1/en/news-5-1-41.html

Plugin Details

Severity: Medium

ID: 801137

Family: Database

Published: 11/24/2009

Updated: 11/24/2009

Nessus ID: 42900

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 11/5/2009

Vulnerability Publication Date: 11/19/2009

Reference Information

CVE: CVE-2008-2079, CVE-2009-4019

BID: 37075, 37076, 37297