MySQL MERGE Table Privilege Escalation

low Log Correlation Engine Plugin ID 801128
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to a flaw that allows attackers to retrieve sensitive files or data.

Description

According to its version number, the installation of MySQL on the remote host may be prone to a flaw where an authenticated user can escalate privileges on the remote database server. Specifically, even if a user has had access revoked to a certain table, they may be able to access it from another table. Successful exploitation would lead to a loss of confidential data.

Solution

Upgrade to version 4.1.21, 5.0.24 or higher.

See Also

dev.mysql.com/doc/refman/5.0/en/news-5-0-24.html

Plugin Details

Severity: Low

ID: 801128

Family: Database

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.2

Temporal Score: 4.3

Vector: CVSS2#AV:A/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2006-4031

BID: 19279