MySQL Community Server 5.1 < 5.1.32 XPath Expression DoS

medium Log Correlation Engine Plugin ID 801118
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to a Denial of Service (DoS) attack.

Description

The version of MySQL 5.1 installed on the remote host is earlier than 5.1.32 and is affected by a denial of service vulnerability. Specifically, a user can cause an assertion failure leading to a server crash by calling 'ExtractValue()' or 'UpdateXML()' using an XPath expression employing a scalar expression as a 'FilterExpr'.

Solution

Upgrade to version 5.1.32 or higher.

See Also

dev.mysql.com/doc/refman/5.1/en/news-5-1-32.html

bugs.mysql.com/bug.php?id=42495

Plugin Details

Severity: Medium

ID: 801118

Family: Database

Nessus ID: 35766

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3.3

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2009-0819

BID: 33972