PHP < 5.1.2 mysqli Error Message Format String

High Log Correlation Engine Plugin ID 801110

Synopsis

The remote host is vulnerable to a remote 'format string' flaw.

Description

The remote host is running a version of PHP that is older than 5.1.2. Versions 5.1.0 and 5.1.1 are potentially vulnerable to a remote format string vulnerability. Specifically, if PHP is configured to log MySQL errors, then an attacker may be able to trigger a condition wherein arbitrary commands or code are executed.

Solution

Upgrade to version 5.1.2 or higher.

See Also

http://.php.net/release_5_1_2.php

Plugin Details

Severity: High

ID: 801110

File Name: 801110.prm

Family: Web Servers

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2006-0200

BID: 16219