PHP 5.3.x < 5.3.13 CGI Query String Code Execution

high Log Correlation Engine Plugin ID 801100


The remote web server uses a version of PHP that is affected by a code execution vulnerability.


PHP versions earlier than 5.3.13 are affected by a code execution vulnerability.

The fix for CVE-2012-1823 does not completely correct the CGI query vulnerability. Disclosure of PHP source code and code execution via query paramenters are still possible.

Note that his vulnerability is exploitable only when PHP is used by CGI-based configurations. Apache with 'mod-php' is not an exploitable configuration.


Upgrade to PHP version 5.3.13 or later.

See Also

Plugin Details

Severity: High

ID: 801100

Family: Web Servers

Published: 6/5/2012

Updated: 6/5/2012

Nessus ID: 59088, 58988, 59056

Risk Information


Risk Factor: High

Base Score: 8.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 5/8/2012

Vulnerability Publication Date: 5/6/2012

Reference Information

CVE: CVE-2012-2336, CVE-2012-2335, CVE-2012-2311

BID: 53388