PHP < 5.2.4 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 801099
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running a version of PHP prior to 5.2.4. This version of PHP is vulnerable to at least 120 distinct security flaws impacting confidentiality, integrity and availability.

Solution

Upgrade to version 5.2.4 or higher.

Plugin Details

Severity: Medium

ID: 801099

Family: Web Servers

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2007-2872, CVE-2007-3378, CVE-2007-3806

BID: 25498