PHP < 4.2.2 Malformed POST Requests

High Log Correlation Engine Plugin ID 801081

Synopsis

N/A

Description

The remote host is running a version of PHP which is older than 4.2.2. This version has a bug which allows an attacker to disable the remote server or execute arbitrary code on it.

Solution

Upgrade to PHP 4.2.2 or downgrade to 4.1.x

Plugin Details

Severity: High

ID: 801081

File Name: 801081.prm

Family: Web Servers

Nessus ID: 11050

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2002-0986

BID: 5562, 5278