PHP < 5.2.10 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 801077


The remote web server uses a version of PHP that is affected by multiple vulnerabilities.


According to its banner, the version of PHP installed on the remote host is earlier than 5.2.10. Such versions are reportedly affected by multiple vulnerabilities :

- A restriction-bypass vulnerability could allow the execution of arbitrary commands when 'safe_mode' is enabled 'safe_mode_exec_dir' is not set. This issue only affects PHP on Windows. (bug 45997)

- A denial of service vulnerability is triggered when an application processes a 'JPEG' image file through a call to the 'exif_read_data()' function. (bug 48378).


Upgrade to PHP version 5.2.10 or later.

See Also

Plugin Details

Severity: Medium

ID: 801077

Family: Web Servers

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:C

Reference Information

CVE: CVE-2009-2687

BID: 35435, 35440