OpenSSL < 0.9.7l / 0.9.8d Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 801062
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is using a version of OpenSSL that is older than 0.9.6m or 0.9.7d There are several bugs in this version of OpenSSL that may allow an attacker to either execute remote code or cause a Denial of Service (DoS).

Solution

Upgrade to version 0.9.7l, 0.9.8d or higher.

See Also

http://.openssl.org/news/secadv_20060928.txt

Plugin Details

Severity: High

ID: 801062

Family: Web Servers

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2006-2940, CVE-2006-2937, CVE-2006-3738

BID: 20249, 20248, 20247