ProFTPd ASCII Newline Character Overflow

High Log Correlation Engine Plugin ID 801023

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running a version of ProFTPd which seems to be vulnerable to a buffer overflow when a user downloads a malformed ASCII file.
An attacker with upload privileges on this host may abuse this flaw to gain a root shell on this host.

Solution

Upgrade to ProFTPd 1.2.9 or 1.2.8p or higher.

Plugin Details

Severity: High

ID: 801023

File Name: 801023.prm

Family: FTP Servers

Nessus ID: 11849

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2003-0831

BID: 8679