Safari < 3.1.1 PCRE Nested Repetition Count Overflow

Medium Log Correlation Engine Plugin ID 801008


The remote host is vulnerable to a buffer overflow.


The remote host is running a version of Apple Safari that is less than 3.1.1.

This version of Safari is vulnerable to a remote exploit. An attacker exploiting this flaw would need to be able to entice a user to browse to a malicious URI and further entice the user to download a file. Successful exploitation would result in the attacker executing arbitary code. In addition, this version of Safari is running a version of AppleWebKit that is less than 525.18. There are a number of flaws associated with that version of AppleWebKit as well.


Upgrade to version 3.1.1 or higher.

See Also

Plugin Details

Severity: Medium

ID: 801008

File Name: 801008.prm

Family: Web Clients

Risk Information

Risk Factor: Medium


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Reference Information

CVE: CVE-2008-1026, CVE-2008-1025, CVE-2008-1024

BID: 28814, 28815, 28813