GNU Wget SSL Certificate Security Bypass

medium Log Correlation Engine Plugin ID 800981
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is affected by a security bypass vulnerability.

Description

The remote host is using a version of Wget earlier than 1.12. Such versions are potentially affected by a security bypass vulnerability because the application fails to properly handle Common Name fields n X.509 certificates that contain an ASCII NULL character.

Solution

Upgrade to Wget 1.12 or later.

See Also

http://.securityfocus.com/advisories/18136

Plugin Details

Severity: Medium

ID: 800981

Family: Web Clients

Published: 10/27/2009

Updated: 10/27/2009

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 9/23/2009

Vulnerability Publication Date: 9/1/2009

Reference Information

CVE: CVE-2009-3490

BID: 36205