Google Chrome < 2.0.172.33 Buffer Overflow vulnerability

High Log Correlation Engine Plugin ID 800970

Synopsis

The remote host contains a web browser that is vulnerable to a buffer overflow attack.

Description

The version of Google Chrome installed on the remote host is earlier than 2.0.172.33. Such versions are reportedly affected by a buffer overflow vulnerability when handling certain responses from HTTP servers. An attacker could exploit this issue to cause a denial of service, or execute arbitrary code with the privileges of the logged on user.

Solution

Upgrade to Google Chrome 2.0.172.33 or later.

See Also

googlechromereleases.blogspot.com/2009/06/stable-beta-update-security-fix.html

Plugin Details

Severity: High

ID: 800970

File Name: 800970.prm

Family: Web Clients

Risk Information

Risk Factor: High

CVSSv2

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Reference Information

CVE: CVE-2009-2121

BID: 35462, 35463