Google Chrome < 17.0.963.56 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 800966

Synopsis

The remote host contains a web browser that is vulnerable to multiple attack vectors.

Description

Versions of Google Chrome earlier than 17.0.963.56 are potentially affected by the following vulnerabilities :

- Integer overflow errors exist related to PDF codecs and libpng. (CVE-2011-3015, CVE-2011-3026)

- A read-after-free error exists related to 'counter nodes'. (CVE-2011-3016)

- Use-after-free errors exist related to database handling, subframe loading, and ddrag-and-drop functionality. (CVE-2011-3017, CVE-2011-3021, CVE-2011-3023)

- Heap-overflow errors exist related to path rendering and 'MKV' handling. (CVE-2011-3018, CVE-2011-3019)

- Unspecified errors exist related to the native client validator and HTTP use with translation scripts. (CVE-2011-3020, CVE-2011-3022)

- Empty x509 certificates can cause browser crashes. (CVE-2011-3024)

- An out-of-bounds read error exists related to h.264 parsing. (CVE-2011-3025)

- A bad variable cast exists related to column handling. (CVE-2011-3027)

Solution

Upgrade to Google Chrome 17.0.963.56 or later.

See Also

googlechromereleases.blogspot.com/2012/02/chrome-stable-update.html

Plugin Details

Severity: High

ID: 800966

File Name: 800966.prm

Family: Web Clients

Published: 2012/02/17

Nessus ID: 57974

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2012/02/15

Vulnerability Publication Date: 2012/02/15

Reference Information

CVE: CVE-2011-3015, CVE-2011-3016, CVE-2011-3017, CVE-2011-3018, CVE-2011-3019, CVE-2011-3020, CVE-2011-3021, CVE-2011-3022, CVE-2011-3023, CVE-2011-3024, CVE-2011-3025, CVE-2011-3026, CVE-2011-3027

BID: 52031, 52049