Google Chrome < 1.0.154.59 Same Origin Policy Bypass Vulnerability

Medium Log Correlation Engine Plugin ID 800916

Synopsis

The remote host contains a web browser that is affected by a same origin bypass vulnerability.

Description

The version of Google Chrome installed on the remote host is earlier than 1.0.154.59. Such versions are reportedly affected by a same origin policy bypass vulnerability when handling URLS with a 'chromehtml: ' protocol which could allow an attacker to run scripts of his choosing on any page or enumerate files on the local disk.

If a user has Google Chrome installed, visiting an attacker-controlled web page in another browser could cause Google Chrome to launch, open multiple tabs, and load scripts that run after navigating to a URL of the attacker's choice (Issue number 9860).

Solution

Upgrade to Google Chrome 1.0.154.59.

See Also

googlechromereleases.blogspot.com/2009/04/stable-update-security-fix.html

Plugin Details

Severity: Medium

ID: 800916

File Name: 800916.prm

Family: Web Clients

Nessus ID: 38154

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

BID: 34704