SeaMonkey < 1.1.16 XSL Transformation Overflow DoS

high Log Correlation Engine Plugin ID 800872
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The installed version of SeaMonkey is earlier than 1.1.16. An XSL transformation vulnerability in such versions can be leveraged with a specially crafted stylesheet to crash the browser or to execute arbitrary code.

Solution

Upgrade to version 1.1.16 or higher.

See Also

http://www.mozilla.org/security/announce/2009/mfsa2009-14.html

http://www.mozilla.org/security/announce/2009/mfsa2009-12.html

Plugin Details

Severity: High

ID: 800872

Family: Web Clients

Nessus ID: 36130

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2009-1169

BID: 34235