Opera < 9.25 Multiple Vulnerabilities

High Log Correlation Engine Plugin ID 800812

Synopsis

The remote host contains a web browser that is affected by several issues.

Description

The version of Opera installed on the remote host reportedly is affected by several issues :

- An issue where TLS certificates could be used to execute arbitrary code.

- The browser processes a 3xx HTTP CONNECT response before a successful SSL handshake, which could allow a man-in-the-middle attacker to execute arbitrary web script in the context of a HTTPS server.

Solution

Upgrade to version 9.25 or higher.

See Also

research.microsoft.com/apps/pubs/default.aspx?id=79323

http://.opera.com/support/search/view/876

http://.opera.com/docs/changelogs/windows/925

http://.opera.com/support/search/view/875

Plugin Details

Severity: High

ID: 800812

File Name: 800812.prm

Family: Web Clients

Nessus ID: 29742

Risk Information

Risk Factor: High

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2009-2061, CVE-2009-2062, CVE-2009-2063, CVE-2007-6520, CVE-2007-6521, CVE-2007-6522, CVE-2007-6524

BID: 26937, 35412