Firefox < 3.0.13/3.5.0 Multiple Vulnerabilities

high Log Correlation Engine Plugin ID 800771
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The installed version of Firefox is earlier than 3.0.13/3.5.0. Such versions are reportedly potentially affected by the following security issues :

- The browser can be fooled into trusting a malicious SSL server certificate with a null character in the host name. (MFSA 2009-42)

- A heap overflow in the code that handles regular expressions in certificate names can lead to arbitrary code execution. (MFSA 2009-43)


Solution

Upgrade to Firefox 3.5.0/3.0.13 or later.

See Also

http://www.mozilla.org/security/announce/2009/mfsa2009-42.html

Plugin Details

Severity: High

ID: 800771

Family: Web Clients

Published: 8/3/2009

Updated: 8/3/2009

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 7/30/2009

Vulnerability Publication Date: 7/30/2009

Reference Information

CVE: CVE-2009-2404, CVE-2009-2408, CVE-2009-2654

BID: 35803, 35888, 35891