Apache Tomcat < 6.0.18 UTF-8 Directory Traversal Arbitrary File Access

Medium Log Correlation Engine Plugin ID 800620

Synopsis

The remote web server is prone to a directory traversal attack.

Description

The version of Apache Tomcat installed on the remote host is affected by a directory traversal issue. By encoding directory traversal sequences as UTF-8 in a request, an unauthenticated remote attacker can leverage this issue to view arbitrary files on the remote host. Note that successful exploitation requires that a context be configured with 'allowLinking' set to 'true' and the connector with 'URIEncoding' set to 'UTF-8', neither of which is a default setting.

Solution

Upgrade to version 6.0.18 or higher.

See Also

http://www.securityfocus.com/archive/1/496168/30/0/threaded

http://www.securityfocus.com/archive/1/499356/30/0/threaded

http://tomcat.apache.org/security-6.html

http://tomcat.apache.org/security-5.html

http://tomcat.apache.org/security-4.html

http://www.securityfocus.com/archive/1/495318/30/0/threaded

Plugin Details

Severity: Medium

ID: 800620

File Name: 800620.prm

Family: Web Servers

Nessus ID: 33866

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Exploitable With

CANVAS (D2ExploitPack)

Reference Information

CVE: CVE-2008-2938

BID: 30633