Apache Tomcat < 4.1.37/5.5.26/6.0.16 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 800618
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote host is vulnerable to multiple attack vectors.


This version of Tomcat is reported to be vulnerable to several flaws. First, the application fails to sanitize user input to the 'RequestDispatcher' method. An attacker exploiting this flaw could request content outside the web root (typically through the use of '../' or similar sequences). If successful, the attacker could gain access to confidential data. Second, the application is vulnerable to a cross-site scripting (XSS) attack via the 'HttpServerResponse.sendError()' function. The user-supplied data is echoed back within the response headers and could lead to arbitrary code being executed within the browser of Tomcat clients.


Upgrade or patch according to vendor recommendations.

See Also

http://www.securityfocus.com/archive/1/[email protected]

Plugin Details

Severity: Medium

ID: 800618

Family: Web Servers

Risk Information


Risk Factor: Medium

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Reference Information

CVE: CVE-2008-1232, CVE-2008-2370

BID: 30496, 30494