Apache Tomcat 5.5.x < 5.5.30 Multiple Vulnerabilities

medium Log Correlation Engine Plugin ID 800613

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

Versions of Tomcat 5.x earlier than 5.5.30 are potentially affected by multiple vulnerabilities :

- The 'WWW-Authenticate' HTTP header for BASIC and DIGEST authentcation may expose the local host name or IP address of the machine running Tomcat. (CVE-2010-1157)

- Several flaws in the handling of the 'Tansfer-Encoding' header could prevent the recycling of buffer. (CVE-2010-2227)

- When running under a SecurityManager, it is possible for web applications to be granted read/write permissions to any area on the file system. (CVE-2010-3718)

Solution

Upgrade to Apache Tomcat 5.5.30 or later.

See Also

tomcat.apache.org/security-5.html

Plugin Details

Severity: Medium

ID: 800613

Family: Web Servers

Published: 2/11/2011

Updated: 2/11/2011

Nessus ID: 47749

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:W/RC:ND

Vulnerability Information

Patch Publication Date: 1/13/2011

Vulnerability Publication Date: 11/22/2010

Reference Information

CVE: CVE-2010-2227, CVE-2010-3718, CVE-2010-1157

BID: 41544, 46177, 39635