Apache Tomcat 5.5.x < 5.5.30 Multiple Vulnerabilities

Medium Log Correlation Engine Plugin ID 800613


The remote web server is vulnerable to multiple attack vectors.


Versions of Tomcat 5.x earlier than 5.5.30 are potentially affected by multiple vulnerabilities :

- The 'WWW-Authenticate' HTTP header for BASIC and DIGEST authentcation may expose the local host name or IP address of the machine running Tomcat. (CVE-2010-1157)

- Several flaws in the handling of the 'Tansfer-Encoding' header could prevent the recycling of buffer. (CVE-2010-2227)

- When running under a SecurityManager, it is possible for web applications to be granted read/write permissions to any area on the file system. (CVE-2010-3718)


Upgrade to Apache Tomcat 5.5.30 or later.

See Also


Plugin Details

Severity: Medium

ID: 800613

Family: Web Servers

Published: 2011/02/11

Nessus ID: 47749

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:W/RC:ND

Vulnerability Information

Patch Publication Date: 2011/01/13

Vulnerability Publication Date: 2010/11/22

Reference Information

CVE: CVE-2010-1157, CVE-2010-2227, CVE-2010-3718

BID: 39635, 41544, 46177