Apache Tomcat 7.0.x < 7.0.11 Security Bypass Vulnerability

Medium Log Correlation Engine Plugin ID 800610


The remote web server is affected by security bypass vulnerability.


Versions of Tomcat 7.0.x earlier than 7.0.11 are potentially affected by a security bypass vulnerability. When a web application is started, 'ServletSecurity' annotations might be ignored which could lead to some areas of the application not being protected as expected.


Upgrade to Apache Tomcat 7.0.11 or later.

See Also


mail-archives.apache.org/mod_mbox/www-announce/201103.mbox/%[email protected]%3E

Plugin Details

Severity: Medium

ID: 800610

Family: Web Servers

Published: 2011/03/11

Nessus ID: 52634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.4

Temporal Score: 4.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Patch Publication Date: 2011/03/11

Vulnerability Publication Date: 2011/03/02

Reference Information

CVE: CVE-2011-1088, CVE-2011-1419

BID: 46685